Montaje del primer moDuino Mega!

Había que aprovechar bien el puente y que mejor forma de hacerlo que montando un moDuino la primera tarde libre. Aun me faltan por llegar los Leds y los conectores de alimentación pero no ha sido impedimento para montar la primera unidad ya que el resto de componentes ya los tenia todos.

En esta entrada no voy a explayarme mucho mas ya que lo importante esta explicado en el vídeo de la entrada, así que para terminar adjunto unas cuantas fotografías que fui realizando mientras construía la placa:

 

Edit:
No he podido esperarme más y ya le he cargado el bootloader y programado el programa blink de ejemplo, funciona perfecto!

10 thoughts on “Montaje del primer moDuino Mega!

    1. Funciona todo perfecto salvo por un error en los pines del USB. Conecte a GND el pin 4 (que permite modo maestro o esclavo) en vez del pin 5 que es realmente el de GND.
      El 5 ha de estar a GND si o si, el pin 4 es opcional. Para arreglarlo basta con hacer un puente con estaño entre los pines 4 y 5.

      A parte de ese fallo lo demás funciona perfecto, te dejo un vídeo en el que se ven interactuando entre si por bluetooth

      http://www.youtube.com/watch?v=uEhyHWy6mv4

      Saludos!

  1. hola como le haz cargado el bootloader al atmega2560 con ISP IDE de arduino o un programador externo?, quisiera saber que software utilizas para hacerlo algún avrdude, yo he intentado pero todos los intentos han sido fallidos no me leen los fuses del atmega. gracias

    1. Hola,

      De las dos formas, como tenia dos placas en cada una de ellas cargue el bootloader de una forma distinta y funciono sin problemas.

      Asegúrate que tienes una versión del IDE reciente, que tienes todo bien conectado y configurado. Debería de irte.

      Saludos.

  2. muchas gracias Alberto Giltesa tendrás algún pequeño tutorial o material de apoyo que me puedas proporcionar para cargarle el bootloader de arduino mega a un microcontrolador virgen atmega2560 16AU, estoy utilizando un arduino duemilanove 328 como programador y la versión de arduino 0022.

    gracias mi correo es reairo_90@hotmail.com

  3. Hola Giltesa,

    ¿tienes subido el esquema de conexiones? Estoy intentando hacer funcionar un atmega2560, le cargo el blink, pero el led no parpadea, para comparar si me he pasado algo por alto, aunque creo que solo es conectar las VCC, GND, el xtal, y deberia funcionar.

    Gracias

    Saludos!

    1. Vale… ya he dado con ello. una pregunta, ¿porque pones dos osciladores? ¿Los condensadores que pones entre Vcc y Gnd son necesarios?

      Yo he conectado los pines 10,3161,80 y 100 directos a 5V. 11, 32, 62, 81 y 99 a gnd. Y en los pines 33 y 34 el xtal, con dos condensadores de 22pF a masa, pero no me funciona.

      Gracias

      Saludos!

    2. Hola Rubén,

      El circuito permite montar dos tipos distintos de oscilador, bien un cristal de cuarzo con sus dos condensadores, o un resonador. Funcionan igual, simplemente es por versatilidad.

      No sé si todos los condensadores son imprescindibles o no, me limito a copiar y adaptar los esquemas de los Arduinos oficiales o compatibles, en todos ellos montan siempre los condensadores así que no creo que estén de adorno.

      En principio hace falta esto como poco:

      mega

      Saludos.

  4. Gracias por responder.

    Lo del XTAL lo tengo montado como la imagen, asi que de ahi no vendrá el problema. (Sin boton reset)

    Los otros condesandores parecen ue son para que sea mas estable la señal, tembien esta en los esquemas del Arduino UNO, y en los montajes que se ven no los llevan, pero si, esta mejor con ellos. No sé si de hay vendrá que a mi no me funcione.

    Lo que no habia visto (En el de Arduino mega oficial no viene) la resistencia de 10K que va al reset.

    Con lo sencillo que es el atmega328, pense que este seria igual.

    Saludos!

Escriba aquí su comentario