Actualizar el phpMyAdmin de zPanel

Actualización 2015/01/17:
Ya no uso este panel de control por lo que no voy a poder resolver dudas sobre él. Ahora uso Parallels Plesk Panel

Al instalar la última versión de zPanel no se instala la última de phpMyAdmin, si no una versión vieja que casi seguro es igual de funcional que la mas reciente pero que estéticamente deja mucho que desear y que solo trae el idioma ingles.

Como realizar la actualización no lleva mucho trabajo pues no esta de mas hacerlo.

Para ello es necesario descargar la versión que queramos de phpMyAdmin, en mi caso la versión phpMyAdmin-4.0.8-all-languages.zip, una vez descargada hay que sustituir todos los ficheros originales por los nuevos en el directorio: /etc/zpanel/panel/etc/apps/phpmyadmin, salvo el fichero config.inc.php que si deberemos de conservar ya que tiene todos los datos de acceso al servicio de MySQL.

Con solo esto ya funcionara el nuevo phpMyAdmin aunque nos advertirá de que faltan cosas por configurar, son las siguientes:

Entre los nuevos ficheros hay un directorio llamado examples, deberemos de ejecutar las consultas contenidas en el fichero create_tables.sql que creara unas tablas que usara la nueva versión de phpMyAdmin.

También hay que crear el usuario pma y darle todos los permisos para la nueva base de datos creada.

Por ultimo en el fichero de configuración habrá que descomentar las lineas de almacenamiento en la base de datos, se pueden encontrar buscando la cabecera/comentario: phpMyAdmin configuration storage settings, entre esas lineas hay una en la que deberemos de insertar la contraseña que le dimos al usuario creado en el punto anterior, es la llamada controlpass.

Y eso es todo, ya tenemos nuestro nuevo phpMyAdmin funcionando!

phpMyAdmin

One thought on “Actualizar el phpMyAdmin de zPanel

  1. yo se que ya no das soporte con Zpanel pero me gustaria saber de que forma se puede instalar phpmyadmin sin afectar el config.inc.php muchas gracias

Escriba aquí su comentario